Degraded dashboard performance
Incident Report for SpeedCurve
Resolved
This incident has been resolved.
Posted Jan 31, 2021 - 20:32 UTC
Update
We've identified the cause of the issue. We introduced a bit of latency with our last infrastructure change that was not anticipated as we continue to migrate to a new platform.

Our solution is to push forward with moving the frontend to our new platform. The team is working aggressively to complete this migration. We are moving with urgency, while continuing to be cautious. We are completing our testing and tentatively plan to migrate the frontend early next week.

Getting the production environment stable for our entire customer base is our highest (and only) priority at the moment. We will continue to provide updates to our status page as we have them.
Posted Jan 28, 2021 - 23:01 UTC
Update
The SpeedCurve API is fully operational again. We are continuing to investigate degraded performance across Synthetic and LUX dashboards.
Posted Jan 22, 2021 - 22:23 UTC
Identified
We have identified an issue which may be impacting performance for some users. We are in the process of implementing a solution.
Posted Jan 18, 2021 - 21:59 UTC
This incident affected: Synthetic Dashboards, LUX Dashboards, and API.