RUM Dashboard Issues

Incident Report for SpeedCurve

Resolved

Everything is now back to normal.
Posted Oct 21, 2025 - 20:13 UTC

Monitoring

AWS is now recovering. Synthetic tests in US East are up to date and we're importing a backlog of RUM page views. No RUM data has been lost and page views in dashboards should be back up to date in the next few hours.
Posted Oct 20, 2025 - 22:02 UTC

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 15:30 UTC

Investigating

Due to the ongoing AWS incident we're experiencing issues displaying RUM data.

Synthetic data is being displayed OK but tests running in US-East may be delayed.

More information on the AWS incident is available from: https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 11:51 UTC
This incident affected: RUM Dashboards.