First Meaningful Paint Issues
Incident Report for SpeedCurve
Resolved
Resolving this for now. It's now a known issue that first meaningful paint is not always correct in the Chrome trace files. First meaningful paint is still considered under development with no "standardized definition by the Google and Chrome teams.
Posted 14 days ago. Aug 08, 2019 - 22:19 UTC
Update
We are continuing to monitor for any further issues.
Posted about 2 months ago. Jul 03, 2019 - 08:39 UTC
Monitoring
The FMP reported via chromeUserTiming has had some funky changes in Chrome 75 and we've been working with the WebPageTest team to find out what's going on and improve the parsing of Chrome user timing events.

It looks like Chrome has started reporting FMP for multiple frames, not just the main frame, and this has thrown the metric out on some pages. We've pushed an update to use the first FMP event we find rather than the last FMP event on the page which should fix the issue with FMP events that appear late in the page load.

We're also seeing other tests with no FMP reported or a FMP of 0 which is nonsensical. FMP is still regarded as a work-in-progress by the Chrome team so we're not sure what their appetite is for fixing issues like this in the Chrome trace.

We strongly recommend using hero rendering times over FMP as we find them a much better representation of the "meaningful" content a user is actually seeing as the page renders. For example FMP doesn't currently take into account when any images render. Google acknowledges that FMP doesn't have a "standardized definition" yet and recommends using user timing marks on hero elements instead.
Posted about 2 months ago. Jul 03, 2019 - 07:51 UTC
Identified
We've identified an issue in Chrome 75 where First Meaningful Paint is not being reported for some URLs.
Posted about 2 months ago. Jul 03, 2019 - 00:18 UTC
This incident affected: Synthetic Data Collection and Synthetic Dashboards.